vmware_vsphere_client

esxupdate error code:14

I deployed some new ESXi 6.0 hosts and proceeded to patch them with VUM. Instead of seeing nice patched hosts after clicking remediate, I was presented with

The host returns esxupdate error code:14. There is an error when resolving dependencies. Check the Update Manager log files and esxupdate log files for more details.

When viewing the Update Manager logs, I see the following:

2016-12-08T14:46:57Z esxupdate: esxupdate: ERROR: File "/build/mts/release/bora-3380124/bora/build/esx/release/vmvisor/sys-boot/lib/python2.7/site-packages/vmwar

2016-12-08T14:46:57Z esxupdate: esxupdate: ERROR: File "/build/mts/release/bora-3380124/bora/build/esx/release/vmvisor/sys-boot/lib/python2.7/site-packages/vmwar

2016-12-08T14:46:57Z esxupdate: esxupdate: ERROR: File "/build/mts/release/bora-3380124/bora/build/esx/release/vmvisor/sys-boot/lib/python2.7/site-packages/vmwar

2016-12-08T14:46:57Z esxupdate: esxupdate: ERROR: File "/build/mts/release/bora-3380124/bora/build/esx/release/vmvisor/sys-boot/lib/python2.7/site-packages/vmwar

2016-12-08T14:46:57Z esxupdate: esxupdate: ERROR: DependencyError: VIB VMware_bootbank_vsanhealth_6.0.0-3000000.3.0.2.34.3544323 requires esx-base >= 6.0.0-2.34, b

2016-12-08T14:46:57Z esxupdate: esxupdate: DEBUG: <<<^@

Apparently there is a dependency error with the VIB VMware_bootbank_vsanhealth_6.0.0-3000000.3.0.2.34.3544323, stating that it requires a version >= 6.0.0-2.34. To resolve, I remediated the patches again but this time I selected only ESXi600-201603201-UG. Per the KB this updates esx-base, vsanhealth, and vsan VIB's. Most importantly, it updates esx-base to version 6.0.0-234.3620759. Once this patch is installed, I am successfuly able to remediate the host with all remaining patches.

Leave a Reply

Your email address will not be published. Required fields are marked *